Subject: wily-9libs and sam-9libs on 24-bit Linux display

From: Jim Crigler <[email-masked]>
Date: Mon, 17 Apr 2000 10:58:20 -0400

Before I delve into the particulars, is does anyone know in advance why
wily-9libson a 24-bit Linux display works fine (modulo I can't use the capslock
key), while sam-9libs (samterm, actually) balks?  They were built in the same
9libs hierarchy at the same time.
-- 
Jim Crigler

__________________________________________________
Do You Yahoo!?
Send online invitations with Yahoo! Invites.
http://invites.yahoo.com

---

From: "Mark H. Wilkinson" <[email-masked]>
Date: Mon, 8 May 2000 18:22:24 -0400

> 9libs hierarchy at the same time.

Probably because sam allocates new bitmaps for things like pop-up menus while wily
doesn't (not having menus) - if you run the libXg test program does it crash when
it gets to the menu test on the same display?

libXg just doesn't work with some bitmap depths, notably 15bpp. However, I thought
it worked Ok on 24bpp displays so I'd like to dig a bit more to find out what's
going on.

-Mark.

---

From: Ed Kubaitis <[email-masked]>
Date: Mon, 8 May 2000 19:16:50 -0400

> it worked Ok on 24bpp displays so I'd like to dig a bit more to find out what's

FWIW, on RH Linux 6.2 recently, I had to backoff 24bpp to 16 to make an
ancient (circa 1993-4) version of libXg/samterm functional.

--------------------------
Ed Kubaitis ([email-masked])
CCSO - University of Illinois at Urbana-Champaign

---

From: Bill Meahan <[email-masked]>
Date: Sun, 24 Sep 2000 15:30:35 -0500

> "Mark H. Wilkinson" wrote:
[snip]
> ancient (circa 1993-4) version of libXg/samterm functional.

Sory for the reply to such an old message but I've recently hit this
myself.

Looking at the code for 9libs, I find a lot of places where the
number of colors is hard-coded at 256 (8-bit depth). I changed these
to 65536 for an experiment,as well as reducing my colordepth to
16-bit, but no joy. Things die where the color map is being read via
the X function. Not being an X programmer, I'm now stuck.

System is Mandrake 7.1 with XFree86 3.3.6

Suggestions or fixes?

Thanks!
-- 
73 de Bill Meahan WA8TZG    [email-masked]
Home for Orphan Hand Tools & Boatanchors (esp. Collins)
Relax -- I use Genuine SMTP Mail, not that M$ virus trap!