From: [email-masked]
Date: Mon, 15 Feb 1993 19:47:52 -0500

it's probably that the host and terminal exchange a pointer
in the protocol and it's known to fit in 4 bytes.
you'll need to fuss with the protocol, making it
incompatible with other architectures.  sigh.
-rob

---

From: David Hogan <[email-masked]>
Date: Mon, 15 Feb 1993 20:11:21 -0500

> incompatible with other architectures.  sigh.

One way of doing this would be to replace the pointers in the
protocol with 32 bit offsets from the start of the arena.  That
way, unless the arena grows to be greater than 4 gigabytes (!) 4
bytes will still be adequate, and the modified samterm should still
interoperate with sams on other architectures.