Subject: no-auto-raise patch

From: [email-masked] (Steve_Kilbane)
Date: Mon, 5 Jul 1993 03:58:53 -0400

a number of people have expressed a vague interest in my patch to stop
windows auto-raising when selected with the mouse. ok, i though, i may
as well post it.

steve

diff -c orig/main.c hacked/main.c
*** orig/main.c	Fri Jul  2 14:12:21 1993
--- hacked/main.c	Mon Jul  5 08:56:20 1993
***************
*** 127,133 ****
  		flborder(which, 0);
  	if(nw){
  		flushtyping(1);
! 		flupfront(nw);
  		flborder(nw, 1);
  		buttons(Up);
  		t=(Text *)nw->user1;
--- 127,133 ----
  		flborder(which, 0);
  	if(nw){
  		flushtyping(1);
! /*		flupfront(nw);  	smk */
  		flborder(nw, 1);
  		buttons(Up);
  		t=(Text *)nw->user1;
diff -c orig/menu.c hacked/menu.c
*** orig/menu.c	Fri Jul  2 14:12:20 1993
--- hacked/menu.c	Fri Jul  2 14:12:52 1993
***************
*** 175,180 ****
--- 175,181 ----
  						i = 0;
  				while(i!=t->front && t->l[i].textfn==0);
  			current(&t->l[i]);
+ 			flupfront(&t->l[i]);	/* smk */
  		}else
  			sweeptext(0, tag[m-NMENU3]);
  		break;

---

From: Scott Schwartz <[email-masked]>
Date: Thu, 8 Jul 1993 14:49:58 -0400

| a number of people have expressed a vague interest in my patch to stop
| windows auto-raising when selected with the mouse. ok, i though, i may
| as well post it.

It's different, but I think I like it.  Thanks Steve.

---

From: "Robert T. Raschke" <[email-masked]>
Date: Fri, 9 Jul 1993 04:35:40 -0400

Hallo,

  das shell-script B in /home/pub/bin ist ein Teil von sam, einem
cut and paste Editor fuer X. Wenn sam gestartet wird, legt es eine
pipe an, in die sam-Kommandos geschickt werden koennen. In sam gibt
es ein Befehl B um Dateien zu laden. Das shell-script, macht nun nichts
anderes als eine Datei in den bestehenden sam zu laden (von einer shell
aus). Dies ist im Prinzip das Gleiche wie emacs-client fuer emacs.

  Robby