Subject: Re: regexps

From: Paul Haahr <[email-masked]>
Date: Tue, 8 Dec 1992 23:28:27 -0500

beginning of word:      (^|[^a-zA-Z0-9])
end of word:            ($|[^a-zA-Z0-9])

'course, you still have to narrow dot by one then.  your definition of 
word may be different from mine, of course, so, maybe
        (^|[ \t]) and ($|[ \t])
would be more appropriate.  (i don't think sam takes \t, but it's
much clearer for purposes of the example.)

---

From: Scott Schwartz <[email-masked]>
Date: Tue, 8 Dec 1992 23:38:20 -0500

| beginning of word:      (^|[^a-zA-Z0-9])
| end of word:            ($|[^a-zA-Z0-9])

I lust for \< and \>.  In vi, something like
	%s/\<foo\>/gnu/
is wonderfully concise.

| 'course, you still have to narrow dot by one then.  

Hey, no fair leaving parts out. :-)