Subject: Re: Samx - one more time ...

From: [email-masked] (Paul Jackson)
Date: Wed, 26 Apr 2000 16:25:47 -0400

Bengt wrote:
|> I am (very low-key) maintaining sam as it is, ...

and grateful we are for your work

|> Perhaps we complement each other? I maintain sam as it is,
|> you enhance it?

As I concluded in a private email thread that branched
off this public thread:

    Seems like what I am dreaming of is really
    yet-another-editor, likely using sam+samx as a code base,
    and for its core design element integrating the gui and
    command interface, but undergoing some major surgery, aimed
    entirely at X11 environments.

    Looks like I should choose yet-another-name for such a
    beast, if it ever gets past being my private toy.  I will
    read the license that comes with Sam again, to be sure I
    am fitting comfortably within its terms.

Not sure if I will go down this path or not - if you're
uncomfortable with it, let me know.

I might call it 'tam' -- because 't' comes after 's',
and because I used to work with a fine chap called
Sam Tam.

=======================================================================
I won't rest till it's the best ...	   Software Production Engineer
Paul Jackson ([email-masked]; [email-masked]) 3x1373 http://sam.engr.sgi.com/pj

---

From: Bengt Kleberg <[email-masked]>
Date: Tue, 25 Apr 2000 10:38:51 -0400

> [email-masked]
> I worry that I might be "splintering" sam

I am (very low-key) maintaining sam as it is, just doing bug fixes and adding
ports (ie making sure that configure works for any new platforms).
Sometime in the future, if time permits, I will try to remove any hardcoded limits
(like the 512 characters samterm -> sam message limit).
I will not attempt to add features.

You have clearly a much broader scoop in your interest for sam.
Perhaps we complement each other? I maintain sam as it is, you enhance it?
Effectivly creating two sams, ofcourse. Presumably sam-as-it-is will stop beeing
used, and that does not matter to me since I am not doing anyhting anyway.

However, have you looked at wily? This is generally considered as a alternative to sam,
and it has loads of the things you seem (to me) to be interested in. Perhaps it would be better
to devout your energy to wily instead?

Best Wishes, Bengt
===============================================================
Everything aforementioned should be regarded as totally private
opinions, and nothing else. [email-masked]
``His great strength is that he is uncompromising. It would make
him physically ill to think of programming in C++.''

---

From: "rob pike" <[email-masked]>
Date: Tue, 25 Apr 2000 08:42:32 -0400

Around here, we spend most of our time avoiding adding
sam features.  But we did add one recently: Redo. Sean
Dorward and I plugged Acme's file management stuff
into Sam a few months ago.  This made it much faster
(a factor of 6 or 7) at reading big files, and made redo
possible.  (The command syntax is u with a negative count;
u- redoes the last undone change).

There have been many other changes triggered by
changes in Plan 9, rendering the Plan 9 source quite
different from the publicly available version of Sam,
but if someone is interested in doing the work I will
send them the code.

-rob

---

From: [email-masked] (Paul Jackson)
Date: Wed, 26 Apr 2000 18:26:30 -0400

|> So, what I'm saying is that anything that changes 'sam'
|> from the Lucent release makes it not sam.

Yes - that agrees with my conclusions so far.

Ah but I'll miss the name 'sam'.  That's my son's name ...

|> SGI's Open Source Server [vs] SourceForge

If it gets to the point that either I am not at SGI or that
there is enough to involve others, then definitely SourceForge.
And if it happens that I left SGI unexpectedly and suddenly, I
can certainly start the SourceForge project at that time, from
the SGI OSS base.

Perhaps sooner to SourceForge, perhaps not.  Doesn't matter
much yet.

---

From: Bengt Kleberg <[email-masked]>
Date: Thu, 27 Apr 2000 04:04:14 -0400

> From: "rob pike" <[email-masked]>

Yes please. I would like to try updateing sam to the current Plan9 version.

One thing: Does this mean that libXg also needs changes?
	As is perhaps known I only look after sam/samterm, not libXg.
	The latter is handled by a skilled person by the name of Mark H Wilkinson.

Best Wishes, Bengt

---

From: "Russ Cox" <[email-masked]>
Date: Thu, 27 Apr 2000 16:17:43 -0400

The graphics model has changed quite a bit,
and there is not currently anything approximating
libXg, at least in such a form.  I have vague notions
of it being a nice thing to have a libXg equivalent
for the new graphics model, and I do have many
of the pieces, but not all, and they're not packaged
correctly.

Rob should correct me if I'm wrong, but I believe
that the protocol between sam and samterm has not
changed, so that you could pick up the aforementioned
sam changes and keep using the current samterm,
if you were not inclined to do battle with X.

Russ