Subject: Subject: fixed bug?

From: [email-masked] (Steve_Kilbane)
Date: Fri, 17 Mar 1995 06:43:12 -0500

In the version of sam that I'm using, if I do the following:

- sam *
- think, "hmm, that includes a binary - i'll delete it"
- D <binary's filename>

then sam attempts to open a window on a file. Not only is
this not necessarily what I want, but on occasion, it's
done this on the file I'm deleting. It's irritating enough,
but last night I did this on a 10MB file, and it took
*ages*.

So, since I consider this a bug, has it been fixed in the
latest release? I haven't upgraded yet, since everything else
works fine...

steve

---

From: [email-masked] (Steve_Kilbane)
Date: Fri, 17 Mar 1995 09:11:39 -0500

rob replied with the following, and asked me to forward it.

steve

> From [email-masked] Fri Mar 17 14:21 GMT 1995
> From: [email-masked]
> To: [email-masked]
> Date: Fri, 17 Mar 1995 09:14:41 EST
> Subject: Re: Subject: fixed bug?
> 
> when you type a command, it must be to an open file, but not an open window.
> i tried what you said and it made no attempt to open a window on the file.
> it did, however, load it in.  is that a bug?  maybe.  but not the one you think.
> sam needs just *some* file to talk to; give it one, and
> 	D file
> will just delete that file.  the problem you're having is that sam is grabbing
> the first file on your list when you type that command because it wants some
> file to be attached to the command (that is very hard to fix, i think); it just
> happened to be a big ugly one in your case.  find another file first, or make
> one with "new", and things will behave well.
> 
> there's talk of mapping acme's buffer management stuff into sam, which
> will make sam much faster at loading files.
>