Subject: sam's memory allocator

From: [email-masked] (Mark H. Wilkinson)
Date: Fri, 7 Apr 1995 06:14:02 -0400

In the SP&E paper about sam it's mentioned that sam uses a custom memory
allocator which allocates strings in a garbage-compacted heap. The version
which is released these days uses just malloc() and realloc(). What was
the reason for throwing the custom allocator away?

-Mark.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Mark H. Wilkinson <[email-masked]>  : Research student in user
University of York, England                 : interface management systems

---

From: [email-masked]
Date: Fri, 7 Apr 1995 11:40:39 -0400

The original allocator was a residue of life on the Blit.  When I moved the
program to a Unicode character set and had to redo the allocation, it
seemed superfluous.