Subject: 9term fix for sunos 4.1.3

From: [email-masked] (Arnold Robbins)
Date: Thu, 2 Jun 1994 10:56:50 -0400

This is what I had to do to compile 9term.1.5.1 on SunOS 4.1.3.

Arnold
---------------
; diff -c pty.c.orig pty.c
*** pty.c.orig	Thu Jun  2 01:35:31 1994
--- pty.c	Thu Jun  2 10:41:53 1994
***************
*** 414,420 ****
--- 414,422 ----
  void
  flushstream(void)
  {
+ #ifdef SOLARIS
  	ioctl(comm_fd, I_FLUSH, FLUSHW);
+ #endif
  }
  
  void

---

From: Scott Schwartz <[email-masked]>
Date: Thu, 2 Jun 1994 15:18:24 -0400

| This is what I had to do to compile 9term.1.5.1 on SunOS 4.1.3.

An alternative fix is to 
	#include <stropts.h>
inside the #ifdef SUNOS near the top.

If you link with X11R6, you'll need to compile with -DXLIB_ILLEGAL_ACCESS
since something pokes around inside the display structure, and they 
decided to make it opaque now.

---

From: Scott Schwartz <[email-masked]>
Date: Thu, 2 Jun 1994 15:21:45 -0400

Another fix: 

diff -ur libtext/click.c libtext-/click.c
--- libtext/click.c	Sat Jun  5 23:30:14 1993
+++ libtext-/click.c	Wed Nov 10 17:17:44 1993
@@ -4,12 +4,12 @@
 #include <frame.h>
 #include <text.h>
 
-static Rune	l1[] =		{ '{', '[', '(', '<', '\253', 0};
+static Rune	l1[] =		{ '{', '[', '(', '<', 0253, 0};
 static Rune	l2[] =		{ '\n', 0};
 static Rune	l3[] =		{ '\'', '"', '`', 0};
 Rune		*left[]=	{ l1, l2, l3, 0};
 
-static Rune	r1[] =		{'}', ']', ')', '>', '\273', 0};
+static Rune	r1[] =		{'}', ']', ')', '>', 0273, 0};
 static Rune	r2[] =		{'\n', 0};
 static Rune	r3[] =		{'\'', '"', '`', 0};
 Rune		*right[]=	{ r1, r2, r3, 0};