Subject: samx2 patches

From: [email-masked]
Date: Thu, 17 Mar 1994 19:25:33 -0500

hi, has anyone applied the samx2 patches to the current (4.1) version of 
sam? i get 3 failures from 'patch', not to mention real bugs probably
introduced. 
if anyone has done this already, could they post them to the list.

btw: a useful patch i have not seen is the removal of 'click-to-type'
i am _very_ new to sam so i dont realy know if this would somehow break
some functionality, but it seems like a simple fix which could save plenty
of mouse clicks. anyone done this?
 
thanks,
guy.

---

From: Andrew Higham <[email-masked]>
Date: Fri, 18 Mar 1994 08:51:18 -0500

> of mouse clicks. anyone done this?

The following patch is a combination of a couple of patches discussed here
before.

Sam works fine without click-to-type.  The only small problem is that it is
a bit too easy to change the focus of commands by moving the mouse pointer
through another file window on its way to the ~sam~ window.  But I find the
default click-to-type has more problems for someone who uses a point-to-type
window manager.

   Andrew

# to apply: patch -d newsam -p1 < thispatch
*** sam4.1/samterm/main.c	Fri Mar 18 11:37:28 1994
--- newsam/samterm/main.c	Fri Mar 18 12:25:02 1994
***************
*** 102,107 ****
--- 102,109 ----
  					scroll(which, 3, fwdbut == 3 ? 3 : 1);
  				else
  					menu3hit();
+ 			}else if(nwhich && nwhich!=which){
+ 				current(nwhich);
  			}
  			mouseunblock();
  		}
***************
*** 128,134 ****
  		flborder(which, 0);
  	if(nw){
  		flushtyping(1);
- 		flupfront(nw);
  		flborder(nw, 1);
  		buttons(Up);
  		t = (Text *)nw->user1;
--- 130,135 ----
*** sam4.1/samterm/menu.c	Fri Mar 18 11:37:28 1994
--- newsam/samterm/menu.c	Fri Mar 18 12:25:06 1994
***************
*** 178,183 ****
--- 178,184 ----
  						i = 0;
  				while(i!=t->front && t->l[i].textfn==0);
  			current(&t->l[i]);
+ 			flupfront(&t->l[i]);
  		}else if(!lock)
  			sweeptext(0, tag[m-NMENU3]);
  		break;