Subject: RE: sam for 95/nt

From: Nigel Roles <[email-masked]>
Date: Mon, 17 Feb 1997 11:35:13 -0500

I modified the UNIX version to do CRLF translation, N space indentation,
and tab to space conversion to observe our company coding standard. Not
difficult.

---------------
Nigel Roles, Symbionics Ltd..

>----------
>From: 	Pete Fenelon[SMTP:[email-masked]]
>Sent: 	17 February 1997 16:26
>To: 	[email-masked]
>Subject: 	sam for 95/nt
>
>In summary -- a lovely piece of work. Just what we've all been waiting for.
>
>One minor caveat, though -- under 95 (don't know about NT) it adopts the
>Unix-y (and indeed right-thinking) LF as newline.... which means it's not
>ideal for editing Windows text files which use CR/LF -- (A) it shows the CR
>half of CR/LF as a CR character and (B) it makes it a tad tricky to use
>files produced with Sam with utilities that aren't wise to the rest of the
>world's conventions on newline...
>
>I suppose this is the *logically* correct behaviour, but to push Sam as an
>editor which the Windows-user community will use, perhaps it should do the
>wrong but  *visually* sensible thing :)
>
>Thoughts -- would it be difficult to bodge sam to treat CR/LF as one rune
>under Windows?
>
>pete
>--
>Pete Fenelon, Infocom UK Ltd. [email-masked]
>

---

From: [email-masked]
Date: Mon, 17 Feb 1997 11:54:19 -0500

Making a file with the commands 
,s/<CR>//g
,s/$/<CR>/g

is helpful, the sam equivalent of /acme/edit/guide.
(I haven't figured out how to type a CR, and just copy them
from other text files).  Another way to add CR's is to open
and close the file in MS-DOS Edit.

One thing that would be very nice is if Shift-Right Button
brought up the middle button menu (cut-paste-etc.), as it
does in Plan 9.

Russ

---

From: erik quanstrom <[email-masked]>
Date: Mon, 17 Feb 1997 12:01:05 -0500

>(I haven't figured out how to type a CR, and just copy them from other text files). 

<compose> X000d

where <compose> is usually the <alt> key. i don't know if this works on the win{nt,95}
version

---

From: Pete Fenelon <[email-masked]>
Date: Mon, 17 Feb 1997 12:15:13 -0500

>where <compose> is usually the <alt> key. i don't know if this works on
the win{nt,95}

ALT-nnn (using the numeric keypad keys) is the way of entering characters
by code under Windows. ALT-013 duplicates the effects of the RETURN key,
however, and for some odd reason ALT-010 inserts the C/R character -- not
quite what I'd expect!  

Strange but true :)

pete
--
Pete Fenelon, 39 Broadway, Fulford, York, YO1 4JP Tel: +44 1904 670334
[email-masked] "I could tell you, but only at consultancy rates".

---

From: <[email-masked]>
Date: Mon, 17 Feb 1997 23:02:00 -0500

> (I haven't figured out how to type a CR, and just copy them from other

Control-m works just fine for me under Unix. Haven't tried the NT
version yet.

Arnold Robbins -- The Basement Computer		| Laundry increases
Internet: [email-masked]			| exponentially in the
UUCP:	dragon!skeeve!arnold			| number of children.
Bitnet:	Forget it. Get on a real network.	|    -- Miriam Robbins