Subject: sam for WinNT?

From: [email-masked] (Arnold D. Robbins)
Date: Fri, 3 Jan 1997 14:40:40 -0500

I know this has been asked before, but I haven't paid attention. I expect
to soon be working on WindozeNT, and would prefer to not have to leave
sam behind.

I would hope that a libg for NT would be enough to get the rest of sam
going, but don't know. Does anyone know of a port of sam to NT?

[ I probably won't reply for a while; heading to USENIX next week. ]

Thanks,

Arnold Robbins		Star Imaging L.L.C.
Phone: +1-404-523-4944	250 Williams Street, Suite 1120, Atlanta, GA 30303
Fax:   +1-404-523-4882	E-mail: [email-masked]
"Oh! Look at all those zeros!" --- Chana Robbins, at age 3.5

---

From: Ed Kubaitis <[email-masked]>
Date: Fri, 3 Jan 1997 16:05:42 -0500

> going, but don't know. Does anyone know of a port of sam to NT?

Boy, that would be great if someone did a port. But a couple
weeks ago when an NT 4.0 box landed on my desk (for a port
of some security related Perl CGI stuff), I figured
'a libg for NT' was one of those things much easier said
than done, especially on a platform where a C compiler
is the exception rather than the rule, and didn't bother
to ask:-) 

FWIW, I'm told that a $27 shareware editor called TextPad
is probably what I want. See http://www.textpad.com/

--------------------------
Ed Kubaitis - [email-masked]
University of Illinois - Urbana - CCSO

---

From: "Simon Turner" <[email-masked]>
Date: Fri, 10 Jan 1997 06:50:03 -0500

Hello,

I have ported sam to W95 and I use this editor 
most of the time. This port may well be ok for WinNT.

My port of sam has left the source files a little 
untidy. At some point I intend to revisit the source 
code, make it presentable and then make it available.

How soon do you need sam? 

For other sam-fans:

Is anybody else interested in a Win95/WinNT version? 
I would appreciate help in testing the ported editor as 
I've become blind to many of it's failings. 
Please let me know if you are interested.

simon
______________________________ Reply Separator _________________________________
Subject: sam for WinNT?
Author:  [email-masked] (Arnold D. Robbins) at WG-ENI-SMTP
Date:    03/01/97 21:15

Thanks,

---

From: [email-masked]
Date: Fri, 10 Jan 1997 16:41:40 -0500

one of the guys in our group, sean quinlan, has a version of sam
that works on NT.  he started from the plan 9 version of sam, which
is based on libg and not libXg, and hacked the bitblt and font handling
in at a fairly low level.

he plans to make it available in binary form, which should be ok
for NT, when he gets the time to package it up.  i have no idea when
that will be, but sean or i will post an announcement to this list when
it is available.

---

From: Nigel Roles <[email-masked]>
Date: Mon, 13 Jan 1997 03:03:05 -0500

I can think of two people here who would willingly pawn their
mother-in-laws for sam on W95. Can the source be available, as it needs
hacks to meet our company coding standard?

Nigel Roles, Symbionics Ltd..