Subject: Re: sam-9libs vs. Linux (RH 6.0)

From: "James A. Robinson" <[email-masked]>
Date: Tue, 28 Mar 2000 13:28:56 -0500

> 16-bit X works, thanks.  Neither 24 nor 32 works,
> however.  Is this likely to be a libXg problem or
> something in samterm per se?

I seem to recall it was a libXg problem. Someone explained that part of
the code expects the depth to be have some properties that don't apply
to 24bit depth (or, I guess, 32bit). I'm sorry that I don't remember
the details.

Jim

---

From: Jim Crigler <[email-masked]>
Date: Tue, 28 Mar 2000 13:15:41 -0500

--- "Jim Robinson" <[email-masked]> wrote:
> > Hmmm ... I asked this on comp.editors a couple of
> weeks ago, and was
> > pointed here as a place to subscribe for real sam
> help.  Under RedHat
> > 6.0 I can run sam -d fine, but when I attempt to
> start the "gui" version,
> > samterm shows up and then disappears.  The sam
> process then dies with a
> > "broken pipe" message.
> 
> I think I responded to your post in Usenet, but in
> case
> you didn't see it: check your color depth. I found
> that
> samterm had problems with (I think) 24 bit depth.
> 
> I normally use 16, and that works fine. I think 32
> should also work.  Try running 'xwininfo' and
> clicking
> on the root window to see what depth it is running
> at.

-- 
Another Jim

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

---

From: Scott Schwartz <[email-masked]>
Date: Wed, 29 Mar 2000 00:10:32 -0500

| I seem to recall it was a libXg problem. Someone explained that part of
| the code expects the depth to be have some properties that don't apply
| to 24bit depth (or, I guess, 32bit). I'm sorry that I don't remember
| the details.

Yes, exactly.  The bug was, libXg only does power-of-two depths, so 24
bits doesn't work.  Annoyingly, most X servers don't let you ask for
more than one depth visual, which would be the obvious workaround for
something like sam.

---

From: Daniel Neri <[email-masked]>
Date: Tue, 28 Mar 2000 19:07:54 -0500

> to 24bit depth (or, I guess, 32bit). I'm sorry that I don't remember

FWIW, sam(term) works fine for me at 24bit depth (running on
OpenBSD/i386 and XFree86 3.3.5). Though this is "plain sam", not based
on 9libs.

Best wishes,
/Daniel

-- 
Daniel Neri
[email-masked]